The only way to increase your current DS1 bandwidth without completely changing the Physical Layer to something such else such as Ethernet is to create a logical bundle with multiple DS1’s interfaces at Layer 2. If you already have the real estate in your Router or your planning on upgrading then there is a simple and easy way to get it done. Here are a couple of Multilink DS1 examples one utilizing Layer 2 PPP encapsulation, and the other with Layer 2 Frame Relay encapsulation. This ability to bundle Serial interface together at Layer 2 is much like what can be accomplished with Layer 2 EtherChannel bundles. 

PPP Features

  • Open Standard
  • Supports both Synchronous and Asynchronous connections.
  • Supports Layer 2 Bundling
  • Supports CHAP / PAP with the help of LCP

Lets start out by simply configuring the controller card type for the both of the T1’s.

R1#config t
R1(config)#card type t1 0 1
R1(config)#exit
R1#

Now that the card type has been defined we can begin channelizing both of T1’s with 24 channels each.

R1#config t
R1(config)#controller t1 0/0/0
R1(config-controller)#cablelength long 0db
R1(config-controller)#channel-group 0 timeslots 1-24
R1(config-controller)#exit
R1(config)#exit
R1#

Now lets do the vary same thing from Controller T1 0/0/1.

R1#config t
R1(config)#controller t1 0/0/1
R1(config-controller)#cablelength long 0db
R1(config-controller)#channel-group 0 timeslots 1-24
R1(config-controller)#exit
R1(config)#exit
R1#

After configuring all 24 channels on controller T1 0/0/0 and all 24 channels on the second controller T1 0/0/1 we now have a total of 1.54 + 1.54 or 3 Meg of bandwidth after the bundle is configured.

R1#config t
R1(config)#interface Multilink1
R1(config-if)#description Layer 2 Multilink
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#load-interval 30
R1(config-if)#priority-group 1
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#exit
R1#

This is the point in the configuration where the Layer 2 bundling really begins to take shape. Much like Etherchannel we are combining the actual Physical Interfaces together in this case the Serial Interfaces to form a single logical interface by adding them to the same Multilink group.

R1#config t
R1(config)#interface Serial0/0/0:0
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#no fair-queue
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#exit
R1#
R1#config t
R1(config)#interface Serial0/0/1:0
R1(config-if)#no ip address
R1(config-if)#encapsulation ppp
R1(config-if)#no fair-queue
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 1
R1(config-if)#exit
R1(config)#exit
R1#

From this point forward we can now start to refer to the logical interface Multilink 1 when making configuration changes such as adding a static route or other related changes.

R1#config t
R1(config)#ip route 0.0.0.0 0.0.0.0 Multilink1
R1(config)#exit
R1#
R1#show ppp multilink active
Multilink1
Bundle name: 10.0.0.1
Remote Endpoint Discriminator: [1] 10.0.0.1
Local Endpoint Discriminator: [1] R1
Bundle up for 1d05h, total bandwidth 3072, load 1/255
Receive buffer limit 24000 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
12 lost fragments, 2458203 reordered
12/5787 discarded fragments/bytes, 0 lost received
0xC3E88E received sequence, 0x9CC611 sent sequence
Member links: 2 active, 0 inactive (max 255, min not set)
Se0/0/1:0, since 1d05h
Se0/0/0:0, since 1d05h

The PPP Authentication Process

  • The CHAP authentication process is a 3 way handshake
  • The CHAP authentication happens periodically after the link is established

Frame Relay Multilink

Much like PPP encapsulation Frame Relay also has the capability of bundling interfaces together at Layer 2 to form a single logical interface with combined bandwidth. When you think about this from a logical standpoint its a lot like configuring a Layer 2 etherchannel / port channel. So if your Provider has the ability to support the same bundled encapsulation upstream with multiple DS1s you can effectively increase your bandwidth by a factor of x. 

Define the 24 channels on the two T1 Controllers.

R1#config t
R1(config)#card type t1 0 1
R1(config)#exit
R1#
R1#config t
R1(config)#controller T1 0/0/0
R1(config-controller)#cablelength long 0db
R1(config-controller)#channel-group 0 timeslots 1-24
R1(config-controller)#exit
R1(config)#exit
R1#
R1#config t
R1(config)#controller T1 0/0/1
R1(config-controller)#cablelength long 0db
R1(config-controller)#channel-group 0 timeslots 1-24
R1(config-controller)#exit
R1(config)#exit
R1#

After configuring all 24 channels on controller T1 0/0/0 and all 24 channels on controller T1 0/0/1 in the example above we now have a total of 3 Meg of bandwidth after the bundle is configured. I’m not going to do anything with controller T1 0/0/2, and controller T1 0/0/3.

The following new encapsulation type MFR0 allows for the formation of the Frame Relay bundle. Simply use the new encapsulation type on the Serial Interfaces defined by the Controllers and you can start creating subinterfaces off of MFR0.

Define a new Layer 2 Frame Relay Header IETF encapsulation type for the bundle.

R1#config t
R1(config)#interface MFR0
R1(config-if)#no ip address
R1(config-if)#encapsulation frame-relay IETF
R1(config-if)#load-interval 30
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#exit
R1#config)#exit
R1#

Add the new Layer 2 IETF Header encapsulation to the Serial Interfaces.

R1#config t
R1(connfig)#interface Serial0/0/0:0
R1(config-if)#description Mulitlink Frame Relay
R1(config-if)#no ip address
R1(config-if)#encapsulation frame-relay MFR0
R1(config-if)#no arp frame-relay
R1(config-if)#exit
R1#
R1#config t
R1(connfig)#interface Serial0/0/1:0
R1(config-if)#description Mulitlink Frame Relay
R1(config-if)#no ip address
R1(config-if)#encapsulation frame-relay MFR0
R1(config-if)#no arp frame-relay
R1(config-if)#exit
R1#

At this point we can create a new subinterfaces with a Header type of MFR0.

R1#
R1(config)#interface MFR0.1 point-to-point
R1(config-if)#description Frame Realy Multilink
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-i)#ip flow ingress
R1(config-if)#ip flow egress
R1(config-if)#no cdp enable
R1(config-if)#frame-relay interface-dlci 100
R1(config-if)#exit
R1#

Now lets take a quick look at the Layer 2 Frame Relay bundle.

R1#show frame-relay multilink mfr0
Bundle: MFR0, State = up, class = A, fragmentation disabled
BID = MFR0
Bundle links:
Serial0/0/0:0, HW state = up, link state = Up, LID = Serial0/0/1:0
Serial0/0/1:0, HW state = up, link state = Up, LID = Serial0/0/0:0

I hope you found this post on Layer 2 Multilink helpful and informative. Be sure to let me know what you think by leaving suggestions, and feedback in the comments section below. You can find out more about these and other articles be checking out recent posts and archives. To learn more about me be sure to check out the About page. And as always thanks again for visiting The Packet.