Dial On Demand Routing or DDR provides a redundant link or network connection over a Public Switched Telephone Networks or PSTN. This could as simple as an Asynchronous dial up modem connection to a more reliable connection such as ISDN. Basically its a connection in waiting. Waiting for the failure of the primary Topology such as MPLS, ATM, or Frame Relay for example. It can also provide a back door if you will or Out Of Band Management.
Some of the more common Dial On Demand Routing options
- Asynchronous Modems with a dedicated POTS line.
- Wireless or Cellular device such as Raven or CradlePoint.
- Dedicated ISDN lines.
ISDN
Basic Rate Interface or BRI consist of 2B + D Integrated Services Digital Network lines primarily used as subscriber lines for voice capable telephone service. The BRI interface configuration provides 2 bearer channels called the B channels at 64 kbit/s each and 1 data channel refereed to as the D channel at 16 kbit/s. The B channels are used for voice or data, and the D channel is used for signalling. The 2 B channels can be combined or aggregated together providing a total data rate of 128 kbit/s.
Common DDR Scenarios
- The Primary WAN link is a full time DDR
- The Primary WAN link is not DDR, and DDR is being utilized as the backup.
Dialer Maps vs Dialer Profiles
R1
- Ethernet0/0 = 172.18.1.1 255.255.255.0
- WAN IP = 10.0.1.1 255.255.255.252
- WAN Layer 2 Frame
- WAN DLCI = 101
- WAN Layer 2 = Frame Relay
- Dialer0 IP = 10.1.1.1 255.255.255.252
- BRI0 Layer 2 = PPP
- ISDN Switch Type = Basic NI
R2
- Ethernet0/0 = 172.18.2.1 255.255.255.0
- WAN IP = 10.0.2.1 255.255.255.252
- WAN Layer 2 Frame
- WAN DLCI = 102
- WAN Layer 2 = Frame Relay
- Dialer0 IP = 10.2.2.1 255.255.255.252
- BRI0 Layer 2 = PPP
- ISDN Switch Type = Basic NI
The Backup DDR Topology
R1#config t
R1(config)#
R1(config)#isdn switch-type basic-ni
R1(config)#exit
R1#
R1#config t
R1(config)#
R1(config)#controller t1 0/0/0
R1(config-controller)#cablelength long 0db
R1(config-controller)#channel-group 0 timeslots 1-24
R1(config-controller)#exit
R1(config)#exit
R1#
R1#config t
R1(config)#
R1(config)#interface s0/0.1 point-to-point
R1(config-if)#description PVC to R2
R1(config-if)#ip address 10.0.1.1 255.255.255.252
R1(config-if)#frame-relay interface-dlci 101
R1(config-if)#backup interface Dialer0
R1(config-if)#exit
R1(config)#exit
R1#
R1#config t
R1(config)#
R1(config)#interface ethernet0/0
R1(config-if)#ip address 172.18.1.1 255.255.255.0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#exit
R1(config)#exit
R1#
Configure ISDN interface on Router R1 and add it to the dialer pool
R1#config t
R1(config)#
R1(config)#interface BRI0/0
R1(config-if)#encapsulation ppp
R1(config-if)#dialer pool-member 1
R1(config-if)#isdn switch-type basic-ni
R1(config-if)#ppp authentication chap
R1(config-if)#ppp multilink
R1(config-if)#exit
R1(config)#exit
R1#
Define some interesting traffic on Router R1 with a simple dialer list
R1#config t
R1(config)#
R1(config)#dialer-list 1 protocol ip permit
R1(config)#exit
R1#
Configure the Dailer Interface and remote name on Router R1
R1#config t
R1(config)#
R1(config)#interface dialer0
R1(config-if)#ip 10.1.1.1 255.255.255.252
R1(config-if)#encapsulation ppp
R1(config-if)#dialer remote-name R2
R1(config-if)#dialer pool 1
R1(config-if)#dialer idle-timeout 900
R1(config-if)#dialer max-call 4096
R1(config-if)#dialer-group 1
R1(config-if)#ppp authentication chap
R1(config-if)#ppp multilink
R1(config)#exit
R1#
Router R2’s Configuration
R2#config t
R2(config)#
R2(config)#isdn switch-type basic-ni
R2(config)#exit
R2#
R2#config t
R2(config)#
R2(config)#controller t1 0/0/0
R2(config-controller)#cablelength long 0db
R2(config-controller)#channel-group 0 timeslots 1-24
R2(config-controller)#exit
R2(config)#exit
R2#
R2#config t
R2(config)#
R2(config)#interface s0/0.1 point-to-point
R2(config-if)#description PVC to R1
R2(config-if)#ip address 10.0.2.1 255.255.255.252
R2(config-if)#frame-relay interface-dlci 101
R2(config-if)#backup interface Dialer0
R2(config-if)#exit
R2(config)#exit
R2#
R2#config t
R2(config)#
R2(config)#interface ethernet0/0
R2(config-if)#ip address 172.18.2.1 255.255.255.0
R2(config-if)#speed 100
R2(config-if)#duplex full
R2(config-if)#exit
R2(config)#exit
R2#
Configure ISDN interface on Router R2 and add it to the dialer pool
R2#config t
R2(config)#
R2(config)#interface BRI0/0
R2(config-if)#encapsulation ppp
R2(config-if)#dialer pool-member 1
R2(config-if)#isdn switch-type basic-ni
R2(config-if)#ppp authentication chap
R2(config-if)#ppp multilink
R2(config-if)#exit
R2(config)#exit
R2#
Define some interesting traffic on Router R2 with a simple dialer list
R2#config t
R2(config)#
R2(config)#dialer-list 1 protocol ip permit
R2(config)#exit
R2#
Configure the Dailer Interface and remote name on Router R2
R2#config t
R2(config)#
R2(config)#interface dialer0
R2(config-if)#ip 10.2.2.1 255.255.255.252
R2(config-if)#encapsulation ppp
R2(config-if)#dialer remote-name R1
R2(config-if)#dialer pool 1
R2(config-if)#dialer idle-timeout 900
R2(config-if)#dialer max-call 4096
R2(config-if)#dialer-group 1
R2(config-if)#ppp authentication chap
R2(config-if)#ppp multilink
R2(config)#exit
R2#
There is an abundance of really good information out there on the Web regarding Dial On Demand routing, but Cisco probably has the best list of example configurations that I have come across with multiple combinations and scenarios surrounding DDR Routing.
I hope that you found this post on ISDN Q921 helpful and informative. Be sure to let me know what you think by leaving your suggestions, and feedback in the comments section below. You can find out more about these and other articles be checking out recent posts and archives. To learn more about myself be sure to check out the About page. And as always thanks again for visiting The Packet.