Enhanced Interior Gateway Routing Protocol or EIGRP is an Cisco proprietary interior gateway protocol suited for many different typologies and media. In a well designed network, EIGRP scales well and provides extremely quick convergence times with minimal network traffic.The best thing about EIGRP is it’s overall simplicity and operation. We can see this in the following simple Topology configuration.

Forming a Neighbor Relationship

  • Must pass the authentication process
  • Must use the same configured AS
  • Must believe that the source address of a received Hello is in the primary subnet
  • The K values must match

EIGRP Utilizes The Following Three Tables

  • The Neighbor Table
  • The Topology Table
  • The Global Routing Table – Common to all Routing Protocols

The Topology Table

  • Successor – The Route that gets installed in the Global Routing Table
  • Feasible Successor or FS – The backup route in waiting 
  • Feasible Distance or FD – The metric value for the lowest path to reach a subnet
  • Reported Distance or RD – The metric distance of a route reported by a neighbor

( Distance / Reported Distance )  ( XXXXXXX YYYYYYY )

R1#show ip eigrp topology
P 10.2.3.0/30, 2 successors, FD is 2681856
.           via 10.0.3.2 (2681856/2169856), Serial0/1
.           via 10.0.2.2 (2681856/2169856), Serial0/0

Lets start off be configuring router R1 for EIGRP 

R1#config t
R1(config)#router eigrp 1
R1(config-router)#redistribute connected
R1(config-router)#redistribute static
R1(config-router)#network 10.0.2.0 0.0.0.3
R1(config-router)#network 10.0.3.0 0.0.0.3
R1(config-router)#no auto-summary
R1(config-router)#eigrp router-id 10.0.2.1
R1(config-router)#exit
R1(config)#exit
R1#

Something that’s often over looked or sometimes forgotten when advtising a network prefix underneath the global routing configuration is that in reality what you’re actually enabling or running EIGRP on the interfaces itself. For example lets take a look at what is really happening when a network is advertised via EIGRP.

R1#show ip eigrp interfaces

IP-EIGRP interfaces for process 1
                Xmit Queue  Mean  PacingTime  Multicast  Pending
Interface  Peers Un/Reliable SRTT  Un/Reliable Flow Timer Routes
Se0/0      1      0/0       44      0/15        50        0
Se0/1      1      0/0       8       0/15        50        0
R1#

Now lets do the same on router R2

R2#config t
R2(config)#router eigrp 1
R2(config-router)#network 10.0.2.0 0.0.0.3
R2(config-router)#network 10.2.3.0 0.0.0.3
R2(config-router)#no auto-summary
R2(config-router)#eigrp router-id 10.0.2.2
R2(config-router)#exit
R2(config)#exit
R2#

As I mentioned above with regards to EIGRP running on the interfaces after enable it via the network command underneath the Router configuration on Router R1. So lets take quick look at Router R2’s interfaces after enabling or configuring EIGRP and advertising R2’s respective networks.

R2#show ip eigrp interfaces

IP-EIGRP interfaces for process 1
                Xmit Queue   Mean  PacingTime  Multicast  Pending
Interface  Peers Un/Reliable  SRTT  Un/Reliable Flow Timer Routes
Se0/0      1      0/0        44      0/15        50        0
Se0/1      1      0/0        8       0/15        50        0
R2#

Now lets do the same on router R3

R3#config t
R3(config)#router eigrp 1
R3(config-router)#redistribute connected
R3(config-router)#redistribute static
R3(config-router)#network 10.0.3.0 0.0.0.3
R3(config-router)#network 10.2.3.0 0.0.0.3
R3(config-router)#network 172.16.3.0 0.0.0.15
R3(config-router)#network 172.17.3.0 0.0.0.15
R3(config-router)#no auto-summary
R3(config-router)#eigrp router-id 10.0.3.2
R3(config-router)#exit
R3(config)#exit
R3#

As with Router R1, and R2 lets take a look at the EIGRP enabled interfaces on Router R3

R3#show ip eigrp interfaces

IP-EIGRP interfaces for process 1
                Xmit Queue   Mean  PacingTime  Multicast  Pending
Interface  Peers Un/Reliable  SRTT  Un/Reliable Flow Timer Routes
Se0/0      1      0/0        44      0/15        50        0
Se0/1      1      0/0        8       0/15        50        0
R3#

Now lets take a look at R1 Topology Table

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.0.2.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.0.2.0/30, 1 successors, FD is 2169856
          via Connected, Serial0/0
P 10.0.3.0/30, 1 successors, FD is 2169856
          via Connected, Serial0/1
P 10.2.3.0/30, 2 successors, FD is 2681856
          via 10.0.3.2 (2681856/2169856), Serial0/1
          via 10.0.2.2 (2681856/2169856), Serial0/0
P 172.17.3.0/28, 1 successors, FD is 2297856
          via 10.0.3.2 (2297856/128256), Serial0/1
P 172.16.3.0/28, 1 successors, FD is 2297856
          via 10.0.3.2 (2297856/128256), Serial0/1

Now lets take a look at R1 EIGRP neighbor Table

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address   Interface    Hold Uptime  SRTT RTO Q Seq 
                          (sec) (ms)          Cnt Num

1  10.0.2.2  Se0/0        13 05:27:35  20 200  0  13
0  10.0.3.2  Se0/1        11 05:27:35  32 200  0  12

Lets take a look at the the routing table on R3

R3#show ip route
Gateway of last resort is not set
172.17.0.0/28 is subnetted, 1 subnets
C         172.17.3.0 is directly connected, Loopback1
172.16.0.0/28 is subnetted, 1 subnets
C          172.16.3.0 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 3 subnets
D          10.0.2.0 [90/2681856] via 10.0.3.1, 06:23:51, Serial0/1
[90/2681856] via 10.2.3.1, 06:23:51, Serial0/0
C          10.0.3.0 is directly connected, Serial0/1
C          10.2.3.0 is directly connected, Serial0/0

Lets take a look at the 172.17.0.0 and 172.16.0.0 subnets on R2 advertised by R3

R2#show ip route 172.17.0.0
Routing entry for 172.17.0.0/28, 1 known subnets
Redistributing via eigrp 1
D       172.17.3.0 [90/2297856] via 10.2.3.2, 06:28:46, Serial0/1
R2#show ip route 172.16.0.0
Routing entry for 172.16.0.0/28, 1 known subnets
Redistributing via eigrp 1
D         172.16.3.0 [90/2297856] via 10.2.3.2, 06:28:52, Serial0/1

I hope you found this simple post on The EIGRP Topology Table helpful and informative. Be sure to let me know what you think by leaving suggestions, and feedback in the comments section below. You can find out more about these and other articles be checking out recent posts and archives. To learn more about me be sure to check out the About page. And as always thanks again for visiting The Packet.