Multicast is a bandwidth conserving technology that reduces traffic by simultaneously delivering a single stream of information to thousands of corporate recipients and homes. Applications that take advantage of multicast technologies include video conferencing, corporate communications, distance learning, and distribution of software, stock quotes, and news.

 Key Multicast Players

  • Multicast Routers
  • Multicast Clients
  • Multicast Source or Server
  • Multicast Routing Protocol
  • Group Management Protocol

Types of Traffic

  • Unicast
  • Broadcast
  • Multicast

Multicast Routing Protocols

  • PIM Spare Mode
  • PIM Dense Mode – Flooding and Pruning

Group Management Protocol

  • Internet Group Management Protocol or IGMP

Rendezvous Points

  • Routers running PIM that form the Multicast Tree

Class D Address and Link Local Scope Address

  • First 4 bits = 1110
  • TTL = 1
  • 224.0.0.0 – 239.255.255.255 – Range
  • 224.0.0.1 – All Host
  • 224.0.0.2 – All Multicast Routers
  • 224.0.0.5 – All OSPF
  • 224.0.0.6 – All OSPF DR
  • 224.0.0.10 – All EIGRP

Notations

  • The ( S, G ) notation represents a Source and Group
  • The ( *, G ) notation represents a Source Wildcard and Group
  • The ( *, * ) notation represents a Source Wildcard and Wildcard Group

Simulation

  • Client – From a Randeveous on the Interface ip igmp join-group 224.X.X.X
  • Server – From the Server ping

Configure R1’s Serial0/0 with PIM dense mode multicast

R1#configure terminal 
R1(config)#ip multicast routing
R1(config)#interface Serial0/0
R1(config-interface)#ip address 10.1.2.1 255.255.255.252
R1(config-interface)#ip pim dense-mode
R1(config-interface)#serial restart-delay 0
R1(config-interface)#exit
R1(config)#exit
R1#

Configure R1’s Serial1/0 wtih PIM dense mode Multicast

R1#configure terminal
R1(config)#interface Serial1/0
R1(config-if)#ip address 10.1.4.1 255.255.255.252
R1(config-if)#ip pim dense-mode
R1(config-if)#serial restart-delay 0
R1(config-if)#exit
R1(config)#exit
R1#

Configure R1 with the EIGRP routing protocol

R1#configure terminal
R1(config)#router eigrp 1
R1(config-router)#network 10.1.2.0 0.0.0.3
R1(config-router)#network 10.1.4.0 0.0.0.3
R1(config-router)#no auto-summary
R1(config-router)#eigrp router-id 100.100.100.100
R1(config-router)#exit
R1(config)#exit
R1#
R1#show ip pim neighbor

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default   DR  Priority,
S - State Refresh Capable
Neighbor            Interface                          Uptime/Expires Ver        DR
Address                                                                                          Prio/Mode
10.1.2.2             Serial0/0                          00:28:47/00:01:33 v2   1 / S
10.1.4.2             Serial0/1                          00:28:44/00:01:35 v2   1 / S

Configure R2 with EIGRP routing protocol

R2#configure terminal 
R2(config)#ip multicast routing
R2(config)#router eigrp 1
R2(config-router)#network 10.1.2.0 0.0.0.3
R2(config-router)#no auto-summary
R2(config-router)#eigrp router-id 10.1.2.2
R2(config-router)#exit
R2(config)#exit
R2#

Configure R2 as a PIM dense mode Multicast rendezvous point

R2#configure termnal
R2(config)#interface Serial0/0
R2(config-if)#ip address 10.0.2.2 255.255.255.252
R2(config-if)#ip pim dense-mode
R2(config-if)#serial restart-delay 0
R2(config-if)#exit
R2(config)#exit
R2#
R2#show ip pim neighbor

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default    DR   Priority,
S - State Refresh Capable
Neighbor            Interface                          Uptime/Expires         Ver   DR
Address                                                                                           Prio/Mode
10.1.2.1             Serial0/0                          00:28:42/00:01:33   v2    1 / S

Configure R3 with EIGRP routing protocol

R3#configure terminal 
R3(config)#ip multicast routing
R3(config)#router eigrp 1
R3(config-router)#network 10.1.3.0 0.0.0.3
R3(config-router)#network 10.2.3.0 0.0.0.3
R3(config-router)#no auto-summary
R3(config-router)#eigrp router-id 10.2.3.2
R3(config-router)#exit
R3(config)#exit
R3#

Configure R3 as a PIM dense mode Multicast rendezvous point

R3#configure terminal
R3(config)#interface Serial0/0
R3(config-if)#ip address 10.2.3.2 255.255.255.252
R3(config-if)#ip pim dense-mode
R3(config-if)#serial restart-delay 0
R3(config-if)#end
R3#
R3#show ip pim neighbor 

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor                 Interface        Uptime/Expires         Ver          DR
Address                                                                                      Prio/Mode
10.2.3.1                  Serial0/0        00:55:09/00:01:16   v2         1 / S
10.0.4.2                  Serial0/1        00:55:09/00:01:17   v2         1 / S
10.0.5.2                  Serial0/2        00:55:09/00:01:15   v2         1 / S

Configure R4 with EIGRP routing protocol

R4#configure terminal
R4(config)#router eigrp 1
R4(config-if)#network 10.1.4.0 0.0.0.3
R4(config-if)#no auto-summary
R4(config-if)#eigrp router-id 10.1.4.2
R4(config-if)#exit
R4(config)#exit
R4#

Configure R4 as a PIM dense mode Multicast rendezvous point

R4#configure terminal
R4(config)#interface Serial0/0
R4(config-if)#ip address 10.1.4.2 255.255.255.252
R4(config-if)#ip pim dense-mode
R4(config-if)#serial restart-delay 0
R4(config-if)#exit
R4(config)#exit
R4#
R4#show ip pim neighbor

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default    DR   Priority,
S - State Refresh Capable
Neighbor            Interface                          Uptime/Expires         Ver   DR
Address                                                                                           Prio/Mode
10.1.4.1             Serial0/0                          00:28:28/00:01:33   v2    1 / S

Configure R5 with EIGRP routing protocol

R5#configure terminal 
R5(config)#ip multicast routing
R5(config)#router eigrp 1
R5(config-router)#network 10.4.5.0 0.0.0.3
R5(config-router)#no auto-summary
R5(config-router)#eigrp router-id 10.4.5.2
R5(config-router)#exit
R5(config)#exit
R5#

Configure R5 as a PIM dense mode Multicast rendezvous point

R5#configure terminal
R5(config)#interface Serial0/0
R5(config-if)#ip address 10.4.5.2 255.255.255.252
R5(config-if)#ip pim dense-mode
R5(config-if)#serial restart-delay 0
R5(config-if)#exit
R5(config)#exit
R5#
R5#show ip pim neighbor

PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default    DR   Priority,
S - State Refresh Capable
Neighbor            Interface                          Uptime/Expires         Ver   DR
Address                                                                                           Prio/Mode
10.4.5.1             Serial0/0                          00:28:22/00:01:33   v2    1 / S